common tasks

Here are step-by-step instructions for completing common tasks:
For information about navigating through a document, see navigation.

open a document for viewing

In the File menu, click Open. In the dialog, navigate to the folder containing the file you want to view, select it, and then click Open to view it. If the file is not one of the
standard document types, then iSilo™ opens the file in text mode.

When you view a given document for the first time, you start at the beginning of the document. A document may consist of one or more pages and the content of each page may either fit entirely within the bounds of the window or if it does not, you can scroll through the page.

By default, a scroll bar appears on the right for scrolling. You can also drag the mouse across the screen to scroll in the direction that you drag. iSilo™ actually provides a number of configurable options for scrolling. See navigation for more on navigating through a document, including information on all the different ways of scrolling and jumping to different parts of a document.


add a bookmark to a document

While viewing a document, you can bookmark the current location using a named bookmark so that you can easily jump back to the bookmarked location at any time by selecting the bookmark from a list of the bookmarks you have added to the document.

To add a bookmark to mark the current location in the document, follow these steps:

  1. In the Marks menu, click Add Bookmark. iSilo™ presents the Add Bookmark dialog and suggests a name for the bookmark, the text of which is taken from the first text line currently at the top of the window.
  2. In the Name field, modify or replace the suggested name with the name you want to give the bookmark.
  3. In the Type field, select Local if you want the bookmark stored in your computer's local settings only or select Document if you want the bookmark stored with the document.
  4. Click Add to add the bookmark or Cancel to not add it.
For more about bookmarks and using them, see
bookmarks.

Tip: In the case where you think you might give a copy of a document to someone but you do not want the recipient to also receive the bookmarks you have set for the document, you can set Local bookmarks for the document rather than Document bookmarks. Since Local bookmarks are not stored in the document, whereas Document bookmarks are, when you copy a document, the Document bookmarks travel with the document to the recipient but the Local bookmarks do not.


search for text within a document

While viewing a document, you can search for text within the document either localized to the current page or through the entire document.

To search for text, follow these steps:

  1. On the tool bar, tap the Find icon . Or in the Edit menu, you can click Find. iSilo™ presents the Find dialog.
  2. In the Find field, enter the text you want to find.
  3. Check Match case if you want the search to be case-sensitive or uncheck it to make the search case-insensitive.
  4. Check Entire document to search the entire document or uncheck it to search only within the current page.
  5. In the Range field, select whether you want to search Down (e.g., forward), Up (e.g., backward), or from Top to Bottom.
  6. Click Find to begin the search or Cancel to cancel.
While iSilo™ searches the document, it presents a progress dialog to show you how far it has searched within the search range and how far it needs to go. You can cancel the search at any time by tapping Cancel. The search stops as soon as iSilo™ finds an occurrence of the text to find or reaches the end of the search range.

If iSilo™ finds an occurrence of the text to find, it jumps to the location of the occurrence and highlights it. You can search for the next occurrence by clicking the Find Again icon on the tool bar or in the Edit menu, click Find Again.


copy text to the clipboard

In the document you are viewing, you can select text and copy it to the clipboard by following these steps:
  1. On the tool bar, click the Select Mode icon or in the Edit menu click Select Mode to enter select mode.
  2. Drag the mouse cursor across the range of text you want to copy. As you do so, the text highlights to show your selection. If you drag to the top or bottom of the screen, the text scrolls so that you can extend the selection.
  3. In the context menu that appears after selecting the text, tap Copy to copy the selected text to the clipboard.

Tip: You can use the Copy Entire Screen, Copy Entire Page, and Copy Entire Document commands in the Edit menu to easily copy the entire text in the window, page, or document, respectively, without needing to either enter select mode or manually select the text.

Note: The amount of text you can copy is limited by the amount of memory available and limitations on how much text the clipboard can hold.


back to contents

©1999-2017 DC & Co. All rights reserved.