document list view

The document list view shows files on your device.

document list layout

The document list has two components:

current view indicator

Immmediately below the title bar of the document list view is the current view indicator. The indicator consists of one or two optional icons and a textual label to show you where in the document list view hierarchy you currently are.

When the document list shows the view list, the indicator label shows Select View without any icons.

The following lists describe what the indicator shows for each of the views.


document list/file list

The document list or file list occupies the space below the current view indicator and above the menu bar. It lists the files and folders within the current folder. Folders always appear before files.

For each file and folder, the list by default shows four pieces of information for each item, described here:

For the following, the list only shows the icon and name.

For each item, the name shows on one line and the date and size show together on a second line. You can optionally hide the date and size line through the List options to allow more items to fit on the screen.

To open a file, move the selection highlight to the file's name, then press the Action button. To enter a folder, move the selection highlight to the folder's name, then press the Action button.

To return to the previous list or to go back up one folder level, press the Back button.

sort order

Use the Sort sub-menu in the List menu, to select a sort order for items in the list. You can sort the current list by any of name, date, or size in either ascending or descending order. The initial sort order is by name in ascending order. To reverse the sort order from ascending to descending or from descending to ascending, select the same sort option again.

The Sort sub-menu is disabled for the Recently Opened view.

Regardless of whether the sort order is ascending or descending, folders in the list always appear before files.


views

The document list view provides five different views of documents you have installed on your device.
To access a given view, first move back up the view hierarchy using the Back button until you get to the Select View list, where you can then select the desired view.

Recently Opened

The Recently Opened view lists the documents you have opened recently, ordered from most recently opened at the top to least recently opened at the bottom. By default, the list shows only the ten most recently opened documents. To change the number of documents listed, modify the List options.

Updated

The Updated view lists documents you have previously opened that have been updated since the last time you opened them.

Categorized

The Categorized view lists documents you have placed into one or more categories. iSilo™ initially creates two top-level categories named Business and Personal.

In addition to being able to select a specific category from the category list, you can also select the [All] listing or the [Uncategorized] listing from the top-level category list. With [All], you get a listing of all categorized documents located anywhere and all uncategorized documents located immediately within any of the favorite folders. With [Uncategorized], you get a listing of all uncategorized documents located immediately within any of the favorite folders.


Favorite Folders

The Favorite Folders view provides an easy way to quickly jump to a list of documents in any folder to which you have assigned an alias. iSilo™ initially creates a favorite folder with the alias iSilo to the \My Documents\iSilo folder.

Some devices have the capability to have two or more storage cards mounted simultaneously. Viewing the contents of a favorite folder provides a unified view of the same folder across all mounted storage cards.

To add a favorite folder to the list, use the Favorite Folder Alias command in the List menu.

To determine the path of the folder associated with each alias, or to rename and delete favorite folders aliases, use the Edit Favorite Folders command in the Tools menu.

Favorite folder aliases are always sorted lexicographically in the list and in the Edit Favorite Folders dialog.


Device & Storage Cards

The Device & Storage Cards view provides a way to browse through all files of all folders on your device.

To list documents installed in the internal storage memory of the device, select Internal Storage from the volume list that you get when you enter the Device & Storage Cards view.

To list the contents of a folder located on a mounted storage card, select the card volume from the volume list and then navigate to the desired folder. The storage card will probably be Storage Card or Storage Card2 if your device supports more than one simultaneously mounted storage card.


file operations

To open a file, move the selection highlight to the file's name, then press the Action button.

To access additional file operations, press the Left Soft Key to activate the List menu. In the List menu, select the File sub-menu to get the following commands for files:


Categories

The Categories command in the File sub-menu presents the Categories dialog, which you can use to categorize the file into one or more categories. You use the Categories dialog to also create, rename, and delete categories.

Tap Done to accept changes you have made to the categorization of the file.

categorizing

To place the file in a category, check the box to the left of the category by moving the selection highlight to the desired category and then pressing the Action button. You can place a file into any number of categories. In the Categorized view, the file shows in the list only when you go to a category to which the file belongs.

To remove the file from a given category, uncheck the box to the left of the category.

creating a new category

To create a top-level category, first select any top-level category, then in the Menu menu, select New. In the New Category dialog, enter into the Name field the name of the new category, then select OK.

To create a sub-category, first select the category into which you want the sub-category created, then in the Menu menu, select New. In the New Category dialog, enter into the Name field the name of the new category, check the Sub-category checkbox, then select OK.

To create a category at the same level as another category, select an existing category at the same level, then in the Menu menu, select New. In the New Category dialog, enter into the Name field the name of the new category, then select OK.

Following are some additional notes about categories:

renaming a category

To rename a category, first select the category to rename, then in the Menu menu, select Rename. Enter the new name into the Name field, then select Rename.

You can not rename a category to that of an existing category at the same level. If you attempt to do so, you get a message informing you that the category already exists.

deleting a category

To delete a category, first select the category to delete, then in the Menu menu, select Delete. You get a message asking you to confirm that you want to delete the selected category and any sub-categories it contains. Select Yes to proceed with deleting the category. Select No to cancel deletion.

If the category has sub-categories, all the sub-categories are also deleted. Any files in the deleted categories are removed from the deleted categories.

Note that deleting a category does not delete the files belonging to those categories.


Delete

Use the Delete command in the File sub-menu to delete the file. iSilo™ asks for confirmation before deleting the file.

Rename

Use the Rename command in the File sub-menu to rename the file. When you do so, iSilo™ presents the Rename File dialog so that you can enter a new name for the file.

Information

Use the Information command in the File sub-menu to view information about the file in the Information dialog that iSilo™ presents. The dialog shows the file name and folder location at the top. Below those fields are the last modification date and time of the file. Next come the Size and Type fields which show the file size and type, respectively.

Copy

Use the Copy command in the File sub-menu to copy or move the file to any favorite folder.

In the Copy File dialog, select the Copy settings/categories option to also copy the document settings and categorizations of the document. Select Delete original if you want to perform the equivalent of moving the file to the new location.

If you need more flexibility in copying files, you can use a third-party file manager.


folder operations

To enter a folder, move the selection highlight to the folder's name, then press the Action button.

For the Favorite Folders view and the Device & Storage Cards view, you can create an alias to a folder by first selecting the folder, then in the Menu menu, select Favorite Folder Alias. If the folder already has an alias, use the command to edit the alias.

Invoking the command shows the Favorite Folder Alias dialog. The Folder Path field shows the path of the folder. You can not edit the path shown. It is only present to show you the path for the alias. In the Alias field, modify the alias to your liking, then select OK to add the alias. In the Favorite Folders view, the alias should appear in the list when you enter the view.


menus

The document list view has two menus:

List menu

File

Use the File sub-menu of the List menu to invoke a file operation.

Favorite Folder Alias

Select Favorite Folder Alias on the List menu to add or modify a favorite folder alias.

Sort By

Use the Sort By sub-menu of the List menu to select a sort order.

Refresh

Select Refresh on the List menu to force the document list to rescan for files and update the document list. By default, the document list automatically updates itself when it detects new or deleted files and folders. However, there are situations where this may not happen.

Filter

Use the Filter sub-menu of the List menu to select what files to display in the document list:

Exit

Select Exit on the List menu to quit the application.

Tools menu

Edit Favorite Folders

Use Edit Favorite Folders on the Tools menu to activate the Edit Favorite Folders dialog to rename and delete favorite folder aliases.

To rename a favorite folder alias, move the selection cursor to the alias, then press the Action button. This presents the Favorite Folder Alias dialog. The Folder Path field shows the path of the folder associated with the alias. You can not edit the path shown. It is only present to show you the path for the alias. In the Alias field, modify the alias to your liking, then select OK to rename the alias.

To delete a favorite folder alias, move the selection cursor to the alias, then press Delete. Note that iSilo™ deletes the alias immediately without asking for confirmation.

Select Done to exit the Edit Favorite Folders dialog.

Options

Use Options on the Tools menu to activate the Options dialog to set options for the following:
List
Select List in the Options dialog to specify settings that affect the document list view display. Here, you can set the following options:
Icons
Select Icons in the Options dialog to select which mini-icons to show. The following list describes the mini-icons:
Settings
Select Settings in the Options dialog to specify settings that affect the saving of a document's local settings and the
Recently Opened view.

A document's local settings include the following items:

iSilo™ creates an individual file in the "iSilo\Settings" of the default documents folder (i.e., \My Documents) for each document's local settings for which it saves. By default, iSilo™ automatically saves the local settings for a document when you close the document. You can change this behavior by changing the Local settings field. The three possible choices are the following: Each local settings file takes up storage space. Over time, if you have viewed many documents, the cumulative space occupied by the local settings files can add up. So by default, when the amount of space used reaches 100KB, iSilo™ deletes the oldest settings files (e.g., based on when the local settings were last written) until the space used goes down to about 90% of the limit. You can increase or decrease this limit by changing the Amount of space to use field.

If you tend to keep a lot of documents around, you may want to increase the limit. If you are tight on space and do not care so much about the local settings of documents you have not viewed recently, then you may want to decrease the limit. The actual size of a local settings file currently depends mostly on how many local bookmarks you have created for the document. However, a rough estimate of the size of a typical local settings file might be anywhere from half a kilobyte to one kilobyte. Using this rough estimate, a limit of 100KB should allow for at least the saving of the local settings for the last 100 documents you have viewed.

For the Recent file list field, specify how many files you want the Recently Opened view to show.

Extensions
Select Extensions in the Options dialog to specify file extensions you want to associate with iSilo™.

Documents in iSilo™ format generally have a file extension of .pdb and rarely, but sometimes, .prc. Palm Doc documents also generally have a file extension of .pdb and sometimes .prc. You can associate either, both, or neither of these extensions with iSilo™.

For each extension that you associate with iSilo™, if you tap on a file with such an extension within the File Explorer program, then it will start iSilo™ with that document.

Please note that iSilo™ does not understand how to read all files with the extension .pdb or .prc. The .pdb extension is generally used to denote files that have the Palm database top-level organizational structure. But what kind of data and how it is stored within this top-level structure is application dependent.

Mode
Select Mode in the Options dialog to specify trial and free mode settings.

While in trial or registered mode, you can use the Free mode option to turn free mode on and off to see what that mode is like.

During the 30-day trial period, you can use the Show trial period reminder option to enable or disable the messages that let you know how many days you have left in your trial period.

System Information

Use System Information on the Tools menu to activate the System Information dialog so that you can determine the user ID you need to provide in order to obtain a registration code for a document that requires a registration code. The user ID is provided in the User ID field.

About iSilo

Use About iSilo on the Options menu to see the iSilo™ About dialog. If the Serial # field at the bottom of the dialog says UNREGISTERED, press the Right Soft Key to select Register to enter your license registration code.

document types

iSilo™ provides direct support for a set of standard document types and a catchall for textually viewing the content of any other document type, useful for viewing plain text files.

standard document types

catchall document type

You can use iSilo™ to open any other type of file for viewing in text mode. This is generally only useful for files in a plain text format as iSilo presents the content as is. If the format of the content is binary or a mix of text and binary, then you may see gibberish.
back to contents

©1999-2017 DC & Co. All rights reserved.