document list view

The document list view shows files on your device.

interface layout

The document list view has two components:

title bar

At the top of the document list view is the title bar.

The left part of the title bar has the folder up indicator and the name of the volume or current folder. If the current folder is not the top level folder of the current document list view, then to the left of the current folder name is the folder up icon to show you that you can move up to the previous level using the <-- key. If the current folder is the top level folder, then the folder up icon does not show.

To the far right of the title bar is the icon of the current document list view.

The following list describes the meaning of volumes and sub-folders for each of the views:


document list/file list

The document list or file list occupies most of the space of the document list view and lists the files and folders within the current folder. Folders always appear before files.

The list has the four columns described here:

You can optionally hide the date and/or size columns through the Document List Options dialog to make more room for the name column.

To open a file, use the arrow keys or the scroll key to move the selection cursor to the file's name, then press either the Enter key or the command button labeled Open. To enter a folder, use the arrow keys or the scroll key to move the selection cursor to the folder's name, then press either the Enter key or the command button labeled Open. For additional operations you can perform on files and folders, see file operations and folder operations.


views

The document list view provides five different views of documents you have installed on your device.
Use the View menu to go to the view you want.

Recently Opened

The Recently Opened view lists the documents you have opened recently, ordered from most recently opened at the top to least recently opened at the bottom. By default, the list shows only the ten most recently opened documents. To change the number of documents listed, go to the Settings page of the Options dialog.

Updated

The Updated view lists documents you have previously opened that have been updated since the last time you opened them.

Categorized

The Categorized view lists documents you have placed into one or more categories. iSilo™ initially creates two top-level categories named Business and Personal.

In addition to being able to select a specific category, you can also select the [All] listing or the [Uncategorized] listing. With [All], you get a listing of all categorized documents located anywhere and all uncategorized documents located immediately within any of the favorite folders. With [Uncategorized], you get a listing of all uncategorized documents located immediately within any of the favorite folders.


Favorite Folders

The Favorite Folders view provides an easy way to quickly jump to a list of documents in any folder to which you have assigned an alias. iSilo™ initially creates a favorite folder with the alias iSilo to the \Documents\iSilo folder.

Some devices have the capability to have two or more storage cards mounted simultaneously. Viewing the contents of a favorite folder provides a unified view of the same folder across all mounted storage cards.

To add a favorite folder to the list, use the Favorite folder alias command in the File menu.

To determine the path of the folder associated with each alias, or to rename and delete favorite folders aliases, use the Edit favorite folders menu command.

Favorite folder aliases are always sorted lexicographically.


Device & Storage Cards

The Device & Storage Cards view provides a way to browse through all files of all folders on your device.

To list documents installed in the internal storage memory of the device, select the volume that begins with C: from the top level of the view. Volumes are identified with a drive letter followed by a colon. In the case of the internal storage memory, the volume drive letter is C. Your device may have other internal storage volumes as well. Internal storage volumes have the device icon () to the left of them.

To list the contents of a folder located on a mounted external storage card, select the card volume from the top level of the view and navigate to the desired folder. External storage volumes have the card icon () to the left of them. The name for the external storage card will probably begin with the drive letter D.


file operations

To open a file, use the arrow keys or the scroll key to move the selection cursor to the file's name, then press either the Enter key or the command button labeled Open. To perform additional file operations, go to the File sub-menu of the File menu, which has the following operations for files:


Categories

The Categories command in the menu presents the Categories dialog, which you can use to categorize the file into one or more categories. You use the Categories dialog to also create, rename, and delete categories.

Press Done to accept changes you have made to the categorization of the file. Press Esc to cancel any such changes. Note that pressing Esc does not revert any changes made to the category list, such as creation, renaming, and deletion of categories.

categorizing

To place the file in a category, check the box to the left of the category. You can place a file into any number of categories. In the Categorized view, the file shows in the list only when you go to a category to which the file belongs.

To remove the file from a given category, uncheck the box to the left of the category.

creating a new category

To create a top-level category, first select any top-level category, then press New. In the New category dialog, enter into the Name field the name of the new category, then press Done.

To create a sub-category, first select the category into which you want the sub-category created, then press New. In the New category dialog, enter into the Name field the name of the new category, set Sub-category to Yes, then press Done.

To create a category at the same level as another category, select an existing category at the same level, then press New. In the New category dialog, enter into the Name field the name of the new category, then press Done.

Following are some additional notes about categories:

renaming a category

To rename a category, first select the category to rename, then press Rename. Enter the new name into the Name field, then press Done.

You can not rename a category to that of an existing category at the same level. If you attempt to do so, you get a message informing you that the category already exists.

deleting a category

To delete a category, first select the category to delete, then press Delete. You get a message asking you to confirm that you want to delete the selected category and any sub-categories it contains. Press OK to proceed with deleting the category. Press Cancel to cancel deletion.

If the category has sub-categories, all the sub-categories are also deleted. Any files in the deleted categories are removed from the deleted categories.

Note that deleting a category does not delete the files belonging to those categories.


Delete

Use the Delete command in the menu to delete the file. iSilo™ asks for confirmation before deleting the file.

Rename

Use the Rename command in the menu to rename the file. When you do so, iSilo™ presents the Rename file dialog so that you can enter a new name for the file.

Send

Use the Send command in the menu to transmit the file via the standard send feature of your device. The send feature is not available on all devices and the specific methods available to send vary by device, but the list of methods may include one or more of the following and possibly others:

Information

Use the Information command in the menu to view information about the file in the Information dialog that iSilo™ presents. The dialog shows the file name and folder location at the top. Below those fields are the last modification date and time of the file. Next come the Size and Type fields which show the file size and type, respectively.

Copy

Use the Copy command in the menu to copy or move the file to any favorite folder.

In the Copy file dialog, set Copy settings to Yes to also copy the document settings and categorizations of the document. Set Delete original after copy to Yes if you want to perform the equivalent of moving the file to the new location.

If you need more flexibility in copying files, you can use a third-party file manager.


folder operations

To enter a folder, use the arrow keys or the scroll key to move the selection cursor to the folder's name, then press either the Enter key or the command button labeled Open.

For the Favorite Folders view and the Device & Storage Cards view, when you have the selection cursor on a folder, you can use the Favorite folder alias command in the File menu to add an alias for the folder to the Favorite folders list. If the folder already has an alias, use the command to edit the alias.

Invoking the command shows the Favorite folder alias dialog. The Folder path field shows the path of the folder. You can not edit the path shown. It is only present to show you the path for the alias. In the Alias field, modify the alias to your liking, then tap Done to add the alias. In the Favorite Folders view, the alias should appear as one of the top-level volumes.


menus

The document list view has these menus:

File menu

Open

Select Open on the File menu to open the currently selected file or enter the currently selected folder.

File

Select File on the File menu to access the
file operations available for the currently selected file.

Favorite folder alias

Select Favorite folder alias on the File menu to
add an alias for the currently selected folder to the Favorite folders list.

Exit

Select Exit on the File menu to quit the application.

View menu

Use the View menu to go directly to any of the document list
views.

List menu

Refresh

Select Refresh on the List menu to force the document list to rescan for files and update the document list. By default, the document list automatically updates itself when it detects new or deleted files and folders. However, there are situations where this may not happen.

Filter

Use Filter on the List menu to select the extensions to list:

The .pdb extension usually denotes files in the Palm database format. Files in iSilo™ format utilizes the Palm database format as the top-level storage format, so usually a file in iSilo™ format will have an extension of .pdb. Files in Palm Doc format also usually have an extension of .pdb since they also utilize the Palm database format as the top-level storage format.

Sometimes Palm Doc files may also have the extension .prc, though that extension is usually used for Palm application files.

Sort by

Use Sort on the List menu to select how to sort the list. For the Recently Opened view, this setting has no effect as the order is always from most recently opened to least recently opened.

You can sort the current list by any of name, date, or size in either ascending or descending order. The initial sort order is by name in ascending order. Select one of Name, Date, or Size in the list to change the sort order to the corresponding selection. To reverse the sort order from ascending to descending or from descending to ascending, select the same sort option again.

Regardless of whether the sort order is ascending or descending, folders in the list always appear before files.


Edit menu

Edit favorite folders

Use Edit favorite folders on the Edit menu to activate the Edit favorite folders dialog to rename and delete favorite folder aliases. The dialog has a list with two columns. The left column shows the aliases and the right column shows the associated folders.

To rename a favorite folder alias, select the alias in the list and then press Rename. This presents the Favorite folder alias dialog. The Folder path field shows the path of the folder associated with the alias. You can not edit the path shown. It is only present to show you the path for the alias. In the Alias field, modify the alias to your liking, then press Done to rename the alias.

To delete a favorite folder alias, select the alias in the list and then press Delete. Note that iSilo™ deletes the alias immediately without asking for confirmation.

Clear recently opened list

Use Clear recently opened list on the Edit menu to clear the recently opened list by deleting the saved information that indicates the order of recently opened files.

Delete settings

Use Delete settings on the Edit menu to delete the settings database that contains individual document settings, categories, favorite folders, etc. After deleting the database, the program exits. You can then restart. This function may be useful in the case where the settings database has become corrupted.

Options

Use Options on the Edit menu to activate the Options dialog to set options for the following:
List
Use the List page of the Options dialog to specify settings that affect the document list view display. Here, you can set the following options:
Icons
Use the Icons page of the Options dialog to set options for the icon that appears to the left of entries.

You can also select the mini-icons you want the document list to show. The following list describes the mini-icons:

Settings
Use the Settings page of the Options dialog to specify settings that affect the saving of a document's local settings and the
Recently Opened view.

A document's local settings include the following items:

iSilo™ creates an individual file in the "c:\system\Apps\iSilo\Settings" folder for each document's local settings for which it saves. By default, iSilo™ automatically saves the local settings for a document when you close the document. You can change this behavior by changing the Local settings field. The three possible choices are the following: Each local settings file takes up storage space. Over time, if you have viewed many documents, the cumulative space occupied by the local settings files can add up. So by default, when the amount of space used reaches 100KB, iSilo™ deletes the oldest settings files (e.g., based on when the local settings were last written) until the space used goes down to about 90% of the limit. You can increase or decrease this limit by changing the Space to use limit field.

If you tend to keep a lot of documents around, you may want to increase the limit. If you are tight on space and do not care so much about the local settings of documents you have not viewed recently, then you may want to decrease the limit. The actual size of a local settings file currently depends mostly on how many local bookmarks you have created for the document. However, a rough estimate of the size of a typical local settings file might be anywhere from half a kilobyte to one kilobyte. Using this rough estimate, a limit of 100KB should allow for at least the saving of the local settings for the last 100 documents you have viewed.

For the Recent file list field, specify how many files you want the Recently Opened view to show.

Mode
Use the Mode page of the Options dialog to specify trial and free mode settings.

While in trial or registered mode, you can use the Free mode option to turn free mode on and off to see what that mode is like.

During the 30-day trial period, you can use the Show trial period reminder option to enable or disable the messages that let you know how many days you have left in your trial period.


Tools menu

System information

Use System information on the Tools menu to activate the System information dialog so that you can determine the user ID you need to provide in order to obtain a registration code for a document that requires a registration code. The user ID is provided in the User ID field.

About iSilo

Use About iSilo on the iSilo menu to see the iSilo™ About dialog. If the Serial # field at the bottom of the dialog says UNREGISTERED, press Register to enter your license registration code.

document types

iSilo™ provides direct support for a set of standard document types and a catchall for textually viewing the content of any other document type, useful for viewing plain text files.

standard document types

catchall document type

You can use iSilo™ to open any other type of file for viewing in text mode. This is generally only useful for files in a plain text format as iSilo presents the content as is. If the format of the content is binary or a mix of text and binary, then you may see gibberish.
back to contents

©1999-2017 DC & Co. All rights reserved.