read view

You use the read view for viewing a document. At the top is the title bar, on the right is the scroll bar, and along the bottom are the tool bar and menu bar. You can hide the scroll bar and the tool bar, but not the title bar nor the menu bar. This page has information about the menus and the tool bar. For information on navigating through a document, see
navigation.

menus

The read view has the following menus:

Edit menu

Copy

Use Copy on the Edit menu to copy the currently selected text to the clipboard. In order to select text, you must place iSilo™ in
select mode.

Copy Entire Screen

Use Copy Entire Screen on the Edit menu to copy the entire text currently displayed on the screen to the clipboard. If the document has been set to prevent copy to clipboard operations, then this menu item appears grayed out.

Copy Entire Page

Use Copy Entire Page on the Edit menu to copy the entire text of the current page to the clipbard. If the document has been set to prevent copy to clipboard operations, then this menu item appears grayed out.

Copy Entire Document

Use Copy Entire Document on the Edit menu to copy the entire text of the current document to the clipboard. If the document has been set to prevent copy to clipboard operations, then this menu item appears grayed out.

Annotate

Use Annotate on the Edit menu to annotate the currently selected text. In order to select text, you must place iSilo™ in select mode.

Note: The Annotate command is also available in the context menu that appears immediately after you select text.

Select File dialog
If you have not yet associated an annotations file for the document, then after invoking the Annotate command, iSilo™ asks you to first select a file for the document's annotations, which may be a new file or an existing annotations file. In this case, you get the Select File dialog with a default name for the annotations file and with a default location set to the same location as the document. You can accept the default name and location or enter a new name and/or select a different location. The annotations file is separate from the document so that you can copy it elsewhere, use it with the document on another platform version of iSilo™, or provide it to another user of the document, among other possible uses.

The default suggested name for the annotations file is the same as the document file name, but with a .isa file name extension. If you do not add a file name extension up to four characters, iSilo™ automatically adds the .isa extension after you tap OK to the dialog.

After tapping OK in the Select File dialog, one of the following cases will apply:

Annotation dialog
The Annotation dialog provides the following three fields for annotating text:

Tap Cancel to not add the annotation and return to the document.

Tap OK to add the annotation and return to the document. The background of the annotated text appears in the selected annotation color. When not in Select Mode, holding the stylus down on any part of the annotated text shows the comment for the annotation and the commands View/Edit and Delete. Use View/Edit to modify any of the comment, color, and text fields of the annotation. Use Delete to delete the annotation with confirmation.

Only one annotation can occupy a given range of text. This means that any portion of an existing annotation that overlaps the new annotation range is removed from the existing annotation. If you add an annotation that completely overlaps any existing annotation, that existing annotation will be automatically deleted. If the new annotation overlaps the middle of an existing annotation, the existing annotation is automatically split into two annotations with identical comment, color, and text fields.

View/Edit Annotations

Use View/Edit Annotations on the Edit menu to activate the Annotations dialog. This dialog lists all annotations in the associated annotations file for the document and provides the following commands:

Annotation Settings

Use Annotation Settings on the Edit menu to activate the Annotation Settings dialog. In the dialog, tap Select File to choose and associate an annotations file with the document. Tap Disassociate File to remove the association between the document and the annotations file. Tap OK to accept any changes you made or tap Cancel to cancel any changes.

Categories

Use Categories on the Edit menu to get the Categories dialog for categorizing the document you are currently viewing. In the dialog, check the checkboxes of the categories into which you want to place the document and uncheck those from which you want to remove the document. Tap OK to accept the changes.

You can also create, rename, and delete categories. See Categories in the section on file operations accessed through the file context menu for more information about doing so.

Document Information

Use Document Information on the Edit menu to activate the Document Information dialog. The dialog displays title, author, publisher, and general information about the document. However, any or all of the title, author, and publisher information may be absent if the creator of the document did not add the corresponding information to the document. The dialog always displays the general information, which consists of the following fields about the current document:

Marks menu

Mark Location

Use Mark Location on the Marks menu to mark the current location using an
unnamed mark. Only one unnamed mark can be set per document. This contrasts with named bookmarks. You can use the unnamed mark to easily mark the current location and return to it at any time later.

Jump To Mark

Use Jump To Mark on the Marks menu to jump to the
unnamed mark.

Add Bookmark

Use Add Bookmark on the Marks menu to activate the Add Bookmark dialog to set a named bookmark at the current location. The Add Bookmark dialog has the following fields:

Tap Add to assign the bookmark. Tap Cancel to not add the bookmark.

If you add a bookmark and it has the same name as an existing bookmark in the document, iSilo™ asks whether you want to replace the existing bookmark. Tap Yes to replace the existing bookmark with the new location. Tap No to not replace the existing bookmark.

Edit Bookmarks

Use Edit Bookmarks on the Marks menu to activate the Edit Bookmarks dialog to perform any of the operations described below. In the Edit Bookmarks dialog, you can select the bookmark type on to which to perform the operations by selecting from the Type popup list.

Top of Page

Use Top of Page on the Marks menu to jump to the top of the current page.

End of Page

Use End of Page on the Marks menu to jump to the bottom of the current page.

Clear History

Use Clear History on the Marks menu to clear the entire
jump history.

Tools menu

Autoscroll

Use Autoscroll on the Tools menu to start autoscroll mode. In autoscroll mode, the page automatically scrolls down at an adjustable constant speed.

While autoscrolling, you can set the autoscroll speed to any of 20 levels. Each incremental level increases the speed by one third relative to the speed of the previous level. To increase the speed, press the hardware down button. To decrease the speed, press the hardware up button. If your device has a jog wheel or jog dial, rotate down to increase the speed and rotate up to decrease the speed. If your device has none of the just described hardware controls, then to increase the speed, touch the content area of the screen and drag up. To decrease the speed, drag down. A drag distance equal to one sixteenth of the height of the content area changes the speed by one step.

Performing any action other than increasing or decreasing the autoscroll speed stops autoscrolling. The easiest way to stop autoscrolling without performing any other action simultaneously is to tap on an inactive area of the screen.

If you use autoscroll often while holding your device in one hand, you may want to consider mapping one of the hardware buttons to the autoscroll action. Pressing such a mapped button starts autoscrolling while pressing it again stops autoscrolling, providing a convenient way for starting and stopping/pausing autoscrolling.

By default, autoscroll uses smooth scrolling. See Scroll options to change the autoscroll mode so that it scrolls a line at a time.

Full Screen

Use Full Screen on the Tools menu to activate full screen mode so that the content display uses the entire screen. In full screen mode, the task bar, tool bar, and command bar are hidden. In addition to using the menu command to activate full screen mode, you can also assign a button to activate full screen mode.

If you are in full screen mode, you can exit the mode in one or more of the following ways:

Options

Use Options on the Tools menu to activate the Options dialog to set options for the following:
Display
Use the Display tab of the Options dialog to specify display settings. It has the following fields:

Please note the following:

Content
Use the Content tab of the Options dialog to specify content settings. It has the following fields:

Please note the following:

UI
Use the UI tab of the Options dialog to change user interface options. It has the following fields:

Please note the following:

Scroll
Use the Scroll tab of the Options dialog to change scroll behavior. It has the following fields:
Region
Use the Region tab of the Options dialog to change the behavior of tapping on different areas of the screen.

The screen is divided into four tap regions. Each region's size and action when tapped upon is configurable. The left part of the Region tab page allows you to change the size of each region and the right side allows you to change the scroll behavior for each region when tapped.

Regions
A tap region can range in size from 14% to 58% of the total height used to display text. You can change the sizes of the regions by dragging up or down the horizontal lines that separate the regions.

While dragging a separator line, it appears as a gray line until you release it. Dragging a single separator line only changes the division of space between the two regions that the line separates, so you may have to change the position of more than one separator line to get your desired region sizes.

Region Action
The region actions determine the scroll behavior when the region is tapped. These are the available actions:

Button
Use the Button tab of the Options dialog to assign actions to the hardware buttons.

The top half of the Button tab page allows you to assign any of the assignable actions to any of the hardware application buttons on an individual basis. Press an application button to see its name and current assignment. By default, each button has the name "Button #", where # is a number. Also by default, each button has no action assigned to it, shown as "Default" in the Assignment field. For each button, you can change its name to something more suitable and assign one of the available actions to it.

The bottom half of the Button tab page allows you to assign any of the assignable actions to the Action and scroll buttons. The Action button is usually associated with pressing of the dial control or scroll control.

Each button can be mapped to any of the following actions:

Note When the Up, Down, Left, and Right buttons have assigned actions of Default, they perform default scroll actions as described in the navigation section of this manual. So if you change the assigned action of any of those buttons, the corresponding buttons no longer have the default scroll behavior.

Font
Use the Font tab of the Options dialog to set the specific font to use for individual font families. It has the following fields: Note: If you are viewing a document in iSilo™ format, changing the Default family font will likely not do anything since content in such documents generally specify some font. So to actually effect a change in the fonts used for documents in iSilo™ format, you will want to modify one or more of the Serif, Sans Serif, and/or Monospace family fonts, depending on which are actually used by the document.

System Information

Use System Information on the Tools menu to activate the System Information dialog so that you can determine the user ID you need to provide in order to obtain a registration code for a document that requires a registration code. The user ID is provided in the User ID field.
Color
Use the Color tab of the Options dialog to select and edit color themes. Selecting a color theme forces all text and background colors of the current document to those of the selected color theme. Select No color theme to have the document display normally. Each document can have an individual color theme setting.

Creating a new color theme
Tap New to create a new color theme. In the Edit Color Theme dialog that appears after tapping New, enter into the Name field a unique name for the color theme. Tap Text and Background to select the text and background colors, respectively, for the color theme.

Modifying a color theme
To modify a color theme, first select the name of the color theme from the list, then tap Edit. In the Edit Color Theme dialog that appears, change the Name field if desired to a new unique name for the color theme. Tap Text and Background to change the text and background colors, respectively, of the color theme.

Deleting a color theme
To delete a color theme, first select the name of the color theme from the list, then tap Delete. iSilo™ asks you to confirm that you want to delete the selected color theme before actually doing so.

About iSilo

Use About iSilo on the Options menu to see the iSilo™ About dialog. If the Serial # field at the bottom of the dialog says UNREGISTERED, tap it to enter your license registration code.

tool bar

The tool bar appears along the bottom of the screen above the menu bar and has the following icons:

You can toggle the state of the tool bar by tapping on the icon in the menu bar that looks like this . If the tool bar is currently shown, tapping the icon hides the tool bar. If the tool bar is currently hidden, tapping the icon shows the tool bar.

Select Mode

Tap the Select Mode icon to enter select mode. When you are in select mode, the Select Mode icon has a frame around it to indicate this. You can exit select mode by tapping on the icon again, in which case the frame around the icon disappears to indicate that you are no longer in select mode.

When in select mode, you select the text you want to copy or annotate and then invoke the corresponding command in the context menu that appears after selecting the text. To select text, drag the stylus across the range of text to which you want to apply the command. Text in the selected range appears highlighted to indicate the selection.

Also, while in select mode, on-screen tap and drag scrolling do not work since you must drag across text on the screen to select it. However, while dragging to select text, if you drag to the top or bottom edge, then the text automatically scrolls in the corresponding direction so that you can extend the selection range in that direction. You can still use the other methods for scrolling.

Find

Tap the Find icon to activate the Find dialog so that you can enter the text you want to find. The Find dialog has the following fields: In the Find dialog, tap the Find button to start the search or tap the Cancel button to dismiss the Find dialog without starting the search.

Find Again

Tap the Find Again icon to search for the next occurrence of the previously searched text. The search continues in the same direction as the previous search.

Note: If there was no previous search in the document in the current session, then the Find Again icon appears grayed out in the tool bar.

Bookmarks

Tap the Bookmarks icon to display a list of the document's named bookmarks. To jump to a bookmark, select it from the list. If there are more bookmarks than can be displayed at once, you can scroll through the list using the up and down arrows that appear along the top and bottom of the list. Tap outside of the list to dismiss the list without jumping to a bookmark.

Note: If the document has no named bookmarks defined, then the Bookmarks icon appears grayed out in the tool bar.

Back

Tap the Back icon to go to the previous location in the jump history.

Note: If there is no previous location in the jump history, then the Back icon appears grayed out in the tool bar.

Forward

Tap the Forward icon to go to the next location in the jump history.

Note: If there is no next location in the jump history, then the Forward icon appears grayed out in the tool bar.

Previous Page

Tap the Previous Page icon to jump to the beginning of the previous page. Before actually jumping, iSilo™ adds the current location to the jump history.

Note: If the current page is page one, then the Previous Page icon appears grayed out in the tool bar.

Go To

The location indicator displays either the current page number or the current location within the page expressed as a percentage, depending on the user interface options. Tap the indicator to activate the Go To dialog to do any of the following:

Next Page

Tap the Next Page icon to jump to the beginning of the next page. Before actually jumping, iSilo™ adds the current location to the jump history.

Note: If the current page is the last page of the document, then the Next Page icon appears grayed out in the tool bar.

Home

Tap the Home icon to go to the top of the home page of the document. If a home page was not specified when the document was converted or if the document format does not support a home page specification, then this results in a jump to the top of the first page of the document.
back to contents

©1999-2017 DC & Co. All rights reserved.