read view

You use the read view for viewing a document. At the top is the title bar, in the middle is the content area, and along the bottom is the status bar.

This page has information about the commands available in the menu. Select Close in the menu to close the current document and return to the document list view. For information on navigating through a document, see navigation.

The read view menu has the following items:


Marks

Use Marks on the menu to access the Marks sub-menu that has the following commands:

Back

Use Back on the Marks sub-menu to go to the previous location in the jump history. By default, pressing the Escape key also performs this action.

Note: If there is a previous location in the jump history, the status bar shows a left-pointing solid arrowhead. So if the status bar does not show the left-pointing solid arrowhead, using the Back command does nothing.

Forward

Use Forward on the Marks sub-menu to go to the next location in the jump history.

Note: If there is a next location in the jump history, the status bar shows a right-pointing solid arrowhead. So if the status bar does not show the right-pointing solid arrowhead, using the Forward command does nothing.

Bookmarks

Use Bookmarks on the Marks sub-menu to display a list of the document's named bookmarks. To jump to a bookmark, move the cursor to highlight the bookmark and then click. If there are more bookmarks than can be displayed at once you can use Up and Down on the directional control to scroll through the list.

By default, clicking also shows the bookmark list.

Note: If the document has no named bookmarks defined, then the Bookmarks command does nothing.

Add Bookmark

Use Add Bookmark on the Marks sub-menu to activate the Add Bookmark dialog to set a named bookmark at the current location. The Add Bookmark dialog has the following fields:

Click Add to assign the bookmark. Press the Escape key to not add the bookmark.

If you add a bookmark and it has the same name as an existing bookmark in the document, iSilo™ asks whether you want to replace the existing bookmark. Click Yes to replace the existing bookmark with the new location. Click No to not replace the existing bookmark.

Edit Bookmarks

Use Edit Bookmarks on the Marks sub-menu to activate the Edit Bookmarks dialog to perform any of the operations described below.

Mark Location

Use Mark Location on the Marks sub-menu to mark the current location using an unnamed mark. Only one unnamed mark can be set per document. This contrasts with named bookmarks. You can use the unnamed mark to easily mark the current location and return to it at any time later.

Jump to Mark

Use Jump to Mark on the Marks sub-menu to jump to the unnamed mark.

Clear History

Use Clear history on the Marks sub-menu to clear the entire jump history.

Go To

Use Go To on the menu to access the Go To sub-menu that has the following commands:

Top of Page

Use Top of Page on the Go To sub-menu to jump to the top of the current page.

End of Page

Use End of Page on the Go To sub-menu to jump to the bottom of the current page.

Home

Use Home on the Go To sub-menu to jump to the top of the home page of the document. If a home page was not specified when the document was converted or if the document format does not support a home page specification, then this results in a jump to the top of the first page of the document.

Percentage of Page

Use Percentage of Page on the Go To sub-menu to get the Go To Percentage of Page dialog. In the dialog, use the Alt key and Left and Right on the directional control to change the percentage location within the current page to jump, then click Go.

Page Number

Use Page Number on the Go To sub-menu to get the Go To Page dialog. In the dialog, enter into the Page Number field the page number to jump to, then click Go.

Previous Page

Use Previous Page on the Go To sub-menu to jump to the beginning of the previous page. Before actually jumping, iSilo™ adds the current location to the jump history.

Note: If the current page is page one, then the Previous page command does nothing.

Next Page

Use Next Page on the Go To sub-menu to jump to the beginning of the next page. Before actually jumping, iSilo™ adds the current location to the jump history.

Note: If the current page is the last page of the document, then the Next page command does nothing.

First Page

Use First Page on the Go To sub-menu to jump to the first page of the document.

Last Page

Use Last Page on the Go To sub-menu to jump to the last page of the document.

Edit menu


Copy Entire Screen

Use Copy Entire Screen on the Edit sub-menu to copy the entire text currently displayed on the screen to the clipboard. If the document has been set to prevent copy to clipboard operations, then using this command presents a message stating that fact and no text is copied.

Copy Entire Page

Use Copy Entire Page on the Edit sub-menu to copy the entire text of the current page to the clipbard. If the document has been set to prevent copy to clipboard operations, then using this command presents a message stating that fact and no text is copied.

Copy Entire Document

Use Copy Entire Document on the Edit sub-menu to copy the entire text of the current document to the clipboard. If the document has been set to prevent copy to clipboard operations, then using this command presents a message stating that fact and no text is copied.

Categories

Use Categories on the Edit sub-menu to get the Categories dialog for categorizing the document you are currently viewing. In the dialog, mark the checkboxes of the categories into which you want to place the document and unmark those from which you want to remove the document. Press the Escape key to exit the dialog.

You can also create, rename, and delete categories. See Categories in the section on file operations in the document list view for more information about this.

Options

Use Options on the Edit sub-menu to activate the Read View Options dialog to set options for the following:

Display

Use the Display options to set the following display option fields:

Please note the following:

User Interface

Use the User Interface options to set the following user interface option fields:

Please note the following:

Scroll

Use the Scroll options to set the following scroll option fields:

Button

Use the Button options to assign actions to the hardware keys or buttons.

The Button Name field allows you to select a key to which to assign an action from the Assignment field.

Note: On some devices, some of the above keys may not be assignable even if they are shown in the Button Name list.

Each button can be mapped to any of the following actions:

Note: When Up, Down, Left, and Right have assigned actions of Default, they perform default scroll actions as described in the navigation section of this manual. So if you change the assigned action of any of those buttons, the corresponding buttons no longer have the default scroll behavior.

Font

Use the Font options to set the specific font to use for individual font families. It has the following fields: Note: If you are viewing a document in iSilo™ format, changing the Default family font will likely not do anything since content in such documents generally specifies some font. So to actually effect a change in the fonts used for documents in iSilo™ format, you will want to modify one or more of the Serif, Sans Serif, and/or Monospace family fonts, depending on which are actually used by the document.

Color

Use the Color options to select and edit color themes. Selecting a color theme forces all text and background colors of the current document to those of the selected color theme. Select No color theme to have the document display normally. Each document can have an individual color theme setting.

Creating a new color theme
To create a new color theme, follow these steps:

  1. Press the Menu key and select New.
  2. Enter a unique name for the color theme.
  3. Choose a text color.
  4. Choose a background color.
  5. Press the Escape key.

Modifying a color theme
To modify a color theme, first select the name of the color theme from the list, then follow these steps:

  1. Press the Menu key and select Edit.
  2. Modify the name for the color theme if desired.
  3. Choose a different text color if desired.
  4. Choose a different background color if desired.
  5. Press the Escape key.

Deleting a color theme
To delete a color theme, first select the name of the color theme from the list. Next, press the Menu key and select Delete. iSilo™ asks you to confirm that you want to delete the selected color theme before actually doing so.


Tools menu


Find

Use Find on the Tools sub-menu to activate the Find dialog so that you can enter the text you want to find. The Find dialog has the following fields: In the Find dialog, click Find to start the search or press the Escape key to dismiss the Find dialog without starting the search.

Find Again

Use Find Again on the Tools sub-menu to search for the next occurrence of the previously searched text. The search continues in the same direction as the previous search.

Note: If there was no previous search in the document in the current session, then the Find Again command does nothing.

Autoscroll

Use Autoscroll on the Tools sub-menu to start autoscroll mode. In autoscroll mode, the page automatically scrolls down at an adjustable constant speed.

While autoscrolling, you can set the autoscroll speed to any of 20 levels. To increase the speed, press Down on the directional control. To decrease the speed, press Up on the directional control. Each increment increases the speed by one third.

Performing any action other than increasing or decreasing the autoscroll speed stops autoscrolling. The easiest way to stop autoscrolling without performing any other action simultaneously is to click.

If you use autoscroll often while holding your device in one hand, you may want to consider mapping one of the hardware buttons to the autoscroll action. Pressing such a mapped button starts autoscrolling while pressing it again stops autoscrolling, providing a convenient way for starting and stopping/pausing autoscrolling.

By default, autoscroll uses smooth scrolling. See Scroll options to change the autoscroll mode so that it scrolls a line at a time.

Full Screen

Use Full Screen on the Tools menu to activate full screen mode so that the content display uses the entire screen. In full screen mode, the title bar and status bar are both hidden. In addition to using the menu command to activate full screen mode, you can also assign a button to activate full screen mode.

If you are in full screen mode, you can exit the mode in one or more of the following ways:

Document Information

Use Document Information on the Tools sub-menu to activate the Document Information dialog. The dialog displays title, author, publisher, and general information about the document. However, any or all of the title, author, and publisher information may be absent if the creator of the document did not add the corresponding information to the document. The dialog always displays the general information, which consists of the following fields about the current document:

System Information

Use System Information on the Tools sub-menu to activate the System Information dialog so that you can determine the user ID you need to provide in order to obtain a registration code for a document that requires a registration code. The user ID is provided in the User ID field.

About iSilo

Use About iSilo on the menu to see the iSilo™ About dialog. If the button at the bottom of the dialog says Register, click it to enter your license registration code.


Close

Select Close on the menu to close the document and return to the document list view.


back to contents

©1999-2017 DC & Co. All rights reserved.